1

I am confounded by this issue. I am able to display a custom SObject checkbox in an inline VF component on the Contact page layout. However, with the same code (this time std controller = Account), I am unable to display the checkbox on the Account page layout even though I can drag and drop the inline VF component onto the Account page.

Here is my VF page code:

<apex:page standardController="Account">
 <apex:form >
  <apex:pageBlock id="theBlock">
<!-- first row -->
    <apex:pageBlockTable value="{!Account}" var="a"> 

        <apex:column headerValue="Fund/Status">
            <apex:outputText >
                <b>EJF</b>
            </apex:outputText>

        </apex:column>
          <apex:column headerValue="On Approved List">
              <apex:inputField value="{!a.EJF_Approved__c}"/> 
          </apex:column>

    </apex:pageBlockTable>
<!-- end of first row -->
  </apex:pageBlock>
 </apex:form>    
</apex:page>

EJF_Approved is the name of the custom checkbox and is in the list of custom fields under Account fields:

enter image description here

enter image description here

On the accounts page, this is what I see - no checkbox:

enter image description here

There are no errors. I use the Pro Edition. Finally, the Account tab is renamed to Investor. I don't think that's the spoiler but just to round up all possibly pertinent information.

It seems like I'm getting something fundamentally wrong here but don't quite see. Please help.

7
  • 1
    Check the field level security and make sure its visible ?could this be issue ? Jul 11 '13 at 9:59
  • Thanks for the response. I use the Pro Edition and I believe there is no field-level security available on this edition, right? So I guess the field is indeed visible. What do you think? Is there a way I can check to see if this is visible (it looks like it is). Unlike custom buttons, custom fields do not have a checkbox 'visible' that can be made use of.
    – Rosh
    Jul 11 '13 at 10:15
  • I confirmed this, in the Pro Edition, I am unable to play around with field-level security simply because I do not have that option while in EE, I do see it.
    – Rosh
    Jul 11 '13 at 10:25
  • I still suspect it has to do with field level security. Is the field on the page layout somewhere else? In Personal, Contact Manager, Group, and Professional Editions, Page Layouts control which fields users can access in related lists, list views, reports, Connect Offline, email and mail merge templates, custom links, and when synchronizing data or importing personal data. See http://login.salesforce.com/help/doc/en/customize_layoutoverview.htm Jul 11 '13 at 14:50
  • The field is on the page layout. I can access this custom field by drag and drop onto the page layout directly on edit mode. However, on attempting to use the same field in the inline VF component on the same Account page layout, the checkbox doesn't appear. On other tabs, Cases, Contacts, it does show up in the inline VF component, just not for Accounts!
    – Rosh
    Jul 11 '13 at 15:03
1

In Personal, Contact Manager, Group, and Professional Editions, Page Layouts control which fields users can access in related lists, list views, reports, Connect Offline, email and mail merge templates, custom links, and when synchronizing data or importing personal data. See http://login.salesforce.com/help/doc/en/customize_layoutoverview.htm

If you add the fields to your page layout, then they will also show up on the Visualforce page, but that kind of defeats the purpose of the inline VF page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.