2

I am trying to create workflows for all the objects on an Enterprise type account(test org created via partner portal). Using the meta-data API I am fetching all the objects and there are some custom objects that I receive. These custom objects have NOT been developed by me, rather they are present in the fresh test org. Here are the ones that I recieve

SFGA__Ad_Group__c
SFGA__Google_Campaign__c
SFGA__Keyword__c
SFGA__Search_Phrase__c
SFGA__Text_Ad__c
SFGA__Version_33_0_3__c

Obviously there could be others also. Now I try to create the workflow using API for these objects and Salesforce throws the following error

unpackaged/workflows/SFGA__Ad_Group__c.workflow(1, 131:Cannot create a new component   
with the namespace: Test_SFGA.  Only components in the same namespace as the 
organization can be created through the API

unpackaged/workflows/SFGA__Google_Campaign__c.workflow(1, 131:Cannot create a new   
component with the namespace: Test_SFGA.  Only components in the same namespace as   
the organization can be created through the API

The Test_ is a tag I am trying to add so that i can distinguish my workflow. I am doing all this via the API so i do not have any package.

What does this error mean? and how can it solved?

  • I don't understand why you need the Test_ prefix. Where exactly do you use it? – rael_kid Jul 10 '13 at 10:42
  • These custom objects are coming from a managed package(not mine) whose namespace is "SFGA". I was adding all by workflows with the "Test_" prefix just for identification. I feel that this problem is occuring because these objects belong to a managed package that is installed and I cannot touch them via my API calls. – auny Jul 10 '13 at 10:59
  • For all the standard object e.g Accounts, Lead etc there is no error. I use the prefix "Test_" for these standard objects also. But there is not problem – auny Jul 10 '13 at 11:03
  • What exactly are you trying to rename? What do you use for manipulation, Force.com IDE? – rael_kid Jul 10 '13 at 12:44
  • No, not the IDE. Its my own java code. I am not trying to rename anything. I am just trying to make a worflow for a custom object. I am naming that workflow with Test_ tag – auny Jul 10 '13 at 12:47
0

The problem with this is that the workflow name becomes Test_SFGA__Text_Ad__c. When we try to upload this workflow salesforce detects from the double underscore __ that a namespace prefix for a custom object is being used. Obviously that namespace prefix belongs to someone else and we cannot created objects with that namespace. The solution is to not let Salesforce see that a namespace prefix is being used. To do that the workflow can be named Test_SFGA_Text_Ad_c and it should work. Notice that we have changed both occurrences of double underscores __ to a single underscore _.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.