1

I think this may be a bug in Summer 13 but I'll take a shot here for some troubleshooting ideas.

Have a Flow as part of managed package that has a Dynamic Choice lookup to Contact object. When type in James should do "all names that contain James". Package has worked fine until earlier this week, first new release after Summer '13. Works fine in Developer org. After we install in customer org the Dynamic Choice is blank when it shouldn't be. Happens under all licenses, including Sys Admin.

Sharing settings are Public/Read Write on Contact. Only 1 record type on Contact which all records have and all profiles have access to. All Contacts have Accounts (so none private). Tried changing owners on Contact back and forth...nothing.

I don't see how to use the Debug logs in this case as the SOQL is inside the Flow, but maybe I'm missing a debug option to see what it's pulling back when Flow executes?

1

Grumble. I'm pretty sure we found the problem so I'll post here since it's still an issue.

For Flows saved after Summer 13 release, the API is trying to append the namespace to STANDARD objects. We just got a create error that said object (namespace)__Contact not found. This would explain the issues. No workaround that I can think of because it's the Flow API behind the scenes that is adding the namespace.

Well, we can't say it's doing this for all standard objects, but for Contact at least it is.

The Flows will work in a Dev org until added to a managed package, which makes sense as there's no namespace associated with it until then. After you add to a Manged Package, if you try the Flow again, same issue, which is why it all worked for us until we packaged everything up.

| improve this answer | |
  • This is still an issue as of this posting. On Known Issues site as resolved which may be the case if you've not encountered it yet but if you already have issue...it's not fixed. Possible workaround suggested on Dev boards under Visual Workflow but didn't work for us. – ddeve Aug 13 '13 at 18:22
  • 1
    Fixed as of August 22 – ddeve Aug 24 '13 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.