2

I'm following the instruction on Trailhead.

When I tried with the enterprise.wsdl I was able to generate the enterprise.jar using force-wsc-37.0.jar, js-1.7R2.jar and ST-4.0.8.jar.

Now I'm trying to generate the partner.jar but I'm getting this error:
Error: Not possible to find neither load the main class com.salesforce.ws.tools.wsdlc

I used the same command line to Enterprise and Partner. ($ java -classpath force-wsc-37.0.jar:js-1.7R2.jar:ST-4.0.8.jar com.sforce.ws.tools.wsdlc partner.wsdl partner.jar)

  • Is the WSC Jar file (force-wsc-37.0.jar) in your working directory, or is it accessible via your classpath? It looks like you have the Rhino library as detailed in Building the Partner.jar API file – Daniel Ballinger Aug 21 '16 at 22:37
  • All the .jar files are in the same classpath, then I just go into the folder by cd example and try to run the command line – Julio C. Boll Aug 22 '16 at 13:14
0

I found my issue.
My Maven was in version 2.2.1 and it required version 3.0 +. I just updated it and worked fine.

Thanks for who helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.