0

I'm using Sublime with Mavensmate to deploy an existing project to my SF dev org. Upon deploying I get the following errors.

Reply.workflow: Cannot create workflow directly; must create the CustomObject first
Question.workflow: Cannot create workflow directly; must create the CustomObject first

I don't see Reply or Question sobjects in my org, how can I enable these objects so my deployment runs successfully?

1 Answer 1

3

The solution was to enable Chatter Answers, the steps I took are as follows:

  1. From within SF org go to Setup navigate to Customize -> Chatter Answers -> Chatter Answers Settings (or search Chatter Answers Settings)
  2. Click Edit button
  3. Check the field Enable Chatter Answers (as well as any other additional features/options you'd like to enable)
  4. Click the Save button

Reply and Question sobjects should now appear in Setup under Customize -> Chatter Answers. The related workflows started deploying successfully after this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .