When validating emails, Marketing Cloud requires 'physical mailing address' AMPscript personalization strings to be present in the email.

If my address exists in a footer Content Area, for example:

<table cellpadding="2" cellspacing="0" width="600" ID="Table5" Border=0>
     <font face="verdana" size="1" color="#444444">This email was sent by:    
     <b>%%Member_Busname%%</b><br>%%Member_Addr%% %%Member_City%%, 
     %%Member_State%%, %%Member_PostalCode%%, %%Member_Country%%<br><br>

Then if I use the following AMPscript code to include the footer Content Area in my HTML Paste email:


When I validate the email, then I get the error:

The email is missing a valid physical mailing address, which must be present on commercial emails per the federal CAN-SPAM Act. Please add a valid postal address in your account settings, or modify your email to include these fields, then you may resend your email.

I can obviously hard code the address personalization strings in each HTML Paste email, but I would prefer not to. Does anyone know of a workaround for this? It appears that Content Areas are not validated, which is rather strange.

2 Answers 2


That validation can be disabled by SFMC Support.

Occasionally we do something like this:

%%[ if 0 == 1 then ]%%
 %%Member_Busname%% %%Member_Addr%% 
 %%Member_City%% %%Member_State%% %%Member_PostalCode%% 
%%[ endif ]%%

My solution was that the Email Reply Address wasn't validated yet (new MC org). Once you verify this, and you fill in everything under 'Company Information' (Account Settings), the problem should be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.