1

The following appears when I click on “Mass Update” in a list of recently created leads:

core.apexpages.exceptions.ApexPagesHandledException: Object type not accessible. Please check permissions and make sure the object is not in development mode:

((CreatedDate = TODAY)) ) ORDER BY StateCode ASC LIMIT 10000 ^ ERROR at Row:1:Column:159 No such column StateCode on entity Lead.

If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

Original queryString was: SELECT Id, Company, Email, LeadSource, Name, Salutation, FirstName, LastName FROM Lead WHERE ( ((IsConverted = FALSE)) AND ((CreatedDate = TODAY)) ) ORDER BY StateCode ASC LIMIT 10000

I tried with leads created before we turned on State/Country Picklists and Mass Update works fine.

The email contact in the AppExchange page for the package lists an email (cchen@salesforce.com) that no longer exists within the company.

Short of disabling the Mass Update package, which would be a bummer, any idea on how to deal with this?

  • I tried reinstalling. No luck. – catalandres Aug 10 '16 at 20:12
  • Cross posted in Salesforce Answers here. – catalandres Aug 10 '16 at 20:12
  • Answer from Salesforce Answers: "It seems that the code running behind does not have accessible check of StateCode field thats why this error is coming. And you can't update the package code." – catalandres Aug 10 '16 at 20:13
  • that package was written long before state and country codes feature came out. However -- you can most definitely edit the code as it is not a managed package – cropredy Aug 11 '16 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.