0

I am trying to connect to salesforce dev env through eclipse. for this, i am creating a force.com project, given the required details to access salesforce metadata.(like username, pwd and org type - selected test.salesforce.com).

When I clicked on next button - a pop window appears saying "unable to fetch organization details with user name i have given. i tried to change the proxy settings too, that does not help me. in preferences->network settings --> i have selected native proxy type settings.

kindly suggest the solution.

  • Have a look at your user within the Salesforce UI. Down the bottom is a list of login attempts. Are you seeing anything there? – Nick Cook Aug 9 '16 at 9:08
1

You need to add the access token with your password or go to network setting and whitelist your IP.

To whitelist your Ip search network setting and add your IP there.

To update the TLS in Eclipse follow these steps:

Force.com IDE Plug-In for Eclipse If you use Java 7, you can’t create or edit projects using the Force.com IDE plug-in for Eclipse unless you disable TLS 1.0. (TLS 1.0 is disabled by default in Java 8.) Update your eclipse.ini file to include this line.

-Dhttps.protocols=TLSv1.1,TLSv1.2

The location of the eclipse.ini file depends on your operating system. For more information, see https://wiki.eclipse.org/Eclipse.ini.

Reference

|improve this answer|||||
  • should this be on eclipse?to add ip address. i am seeing the two boxes - proxy entries and proxy bypasses. in which i am supposed to add? – Venkatz Aug 9 '16 at 8:55
  • @Venkatz No you need to whitelist IP on SF. – Tushar Sharma Aug 9 '16 at 8:57
  • i have add my sys ip to sf. and tried to login, getting the same error. showing tsl1.0 service is disabled – Venkatz Aug 9 '16 at 9:17
  • @Venkatz check my updated answer. – Tushar Sharma Aug 9 '16 at 11:42
0

You need to add your IP to setup->network access page

enter image description here

then you will be able to create a project in eclipse

|improve this answer|||||
  • i followed the same thing. still getting the error. – Venkatz Aug 9 '16 at 9:29
  • you can add your ip at profile level and try once. – SFDC Learner Aug 9 '16 at 9:32
  • i am sys admin profile, the ip already was included at this profile. – Venkatz Aug 9 '16 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.