2

Is it everyone that faces the same issue?

I am trying to upload one class and it takes up to half a day. This platform supposedly should be easy to manipulate, but one hour in today and I can't deploy my changes.

Has anyone tried contact their support with this issue?

Take a look below, took me half a day to make a minor change.

http://i.stack.imgur.com/Z2BFZ.png

3
  • That's not normal. Did you try to contact Salesforce support? – rael_kid Jul 3 '13 at 9:09
  • Changesets are painfully slow sometimes for it get on the production system. I have experienced sometimes a delay of 30 - 45 mins but never half a day. i prefer using eclipse to do my move to production. I think you need to contact Support – Prady Jul 3 '13 at 9:37
  • 24 hours later, change set is not there. – dzh Jul 4 '13 at 15:53
2

Instead of waiting for change set in salesforce, you can deploy with Force Eclipse IDE or with Force Migration Tool. Deployments can be done quickly with this.

3
  • My colleague wasn't too fond of it as well, occasionally deployments taking hours. I will give it a go. – dzh Jul 3 '13 at 10:20
  • It worked when deployed from Force.com IDE, even though it timed-out. However change sets haven't uploaded yet. – dzh Jul 3 '13 at 11:32
  • Using IDE and Migration Tools create API Calls with Timeout but Change set doesn't have any timeout restrictions. That is why the change sets are queued and may come sometimes later. Also please make sure that the object you're going to add the fields is not currently involved in any batches/schedules. In such cases stop the schedule and re-schedule after deploying your new fields. – Vignex Jul 3 '13 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.