0

I am trying to clone one developer org to another using salesforce migration tool and ANT. Mailchimp 1.66 is installed on my source org and the same I installed on my target org before deploying now when I run the command for deploying it throws following error.

Error: The specified Package Version number does not exist for that Package: MC4SF, 1.33

Actually it is looking for mailchimp 1.33 on the target org. and I looks at details of mailchimp on the source org than 1.33 was the fist installed version.

So what is the issue and how can i resolve this any help will be appreciated thanks

1 Answer 1

0

In the metadata xml files you downloaded, you maybe have components (ApexClass, VFPage, etc.) that depend on mailchimp 1.33.

You can find the dependency in the files ending with *-meta.xml

try to find the dependency to Mailchimp 1.33 Something like this:

<packageVersions>
    <majorNumber>1</majorNumber>
    <minorNumber>33</minorNumber>
    <namespace>Mailchimp </namespace>
</packageVersions>

and replace it with

<packageVersions>
    <majorNumber>1</majorNumber>
    <minorNumber>66</minorNumber>
    <namespace>Mailchimp </namespace>
</packageVersions>

in all *-meta.xml files...

2
  • Thanks akram for your answer but I have around 400 VF pages and components so for each I have to change this manually?? Jul 28, 2016 at 12:37
  • You can use a tool for that to mass edit the files... (open all files in notepad++ for example and do a replace in all opened file for example) (Sorry I don't see any other way to do it)
    – Akram G
    Jul 28, 2016 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .