1

Approval Process We have a process builder which auto approves a quote based on a specific approval process with a criteria defined as discountpercent__c > 2.Wherein the field discountpercent__c is a rollup summary field and sums it up based on discount field in quote. Now the problem is that the quote gets auto approved only when it is edited.If we try creating a new record it throws the following error

Workflow Action Failed to Trigger Flow The record couldn’t be saved because it failed to trigger a flow. A flow trigger failed to execute the flow with version ID 30136000000DWbb. Contact your administrator for help.

Click here to return to the previous page.

But manually submitting the record works fine.Any idea on why Process builder causes such error???

Updated Error:

This report lists the elements that the flow interview executed. The report is a beta feature. We welcome your feedback on IdeaExchange.

Flow Details Flow Name: Quote_Approval Type: Workflow Version: 1 Status: Active

Flow Interview Details Interview Label: Quote_Approval-1_Quote Current User: Baku A (00536000002df2q) Start time: 7/28/2016 2:16 AM Duration: 0 seconds

How the Interview Started Baku A (00536000002df2q) started the flow interview. Some of this flow's variables were set when the interview started. myVariable_old = null myVariable_current = 0Q036000000AYlnCAG

ASSIGNMENT: myVariable_waitStartTimeAssignment {!myVariable_waitStartTimeVariable} Equals {!Flow.CurrentDateTime} Result {!myVariable_waitStartTimeVariable} = "7/28/2016 2:16 AM"

DECISION: myDecision Executed this outcome: myRule_1 Outcome conditions: and 1. {!formula_myRule_1} (true) Equals true Logic: All conditions must be true (AND)

SUBMIT FOR APPROVAL: myRule_1_A1 Inputs: objectId = {!myVariable_current.Id} (0Q036000000AYlnCAG) comment = null processDefinitionNameOrId = Quote_Approval skipEntryCriteria = false

Error Occurred: No applicable approval process was found.

  • Can you paste your debug logs during this. It would tell us exactly at which component in the process builder, the flow failed. Also, an email would have been sent (to the last modified by user of the process builder) with the error details. Please review. – sfdcFanBoy Jul 28 '16 at 9:30
  • I have updated my question @sfdcFanBoy – Priyalakshmi Jul 28 '16 at 9:50
1

Since the discountpercent__c is a roll-up summary. At creation your record won't have a value (you can't have children before you insert a record as you need it's Id).

What is happening is that you flow is calling the approval process, but the record does not pass the entry criteria and hence the error you found.

A way to avoid that is to make sure the entry criteria for your flow is the same as the Approval Process.

  • From the debug logs - Error Occurred: No applicable approval process was found. – sfdcFanBoy Jul 28 '16 at 10:18
  • Exatcly. That means that the record didn't match the criteria for the approval process., – Fernando Gavinho Jul 28 '16 at 10:19
  • THanks @Fernando Gavinho, Do you mean the criteria defined for process builder should be the same as approval process entry criteria? – Priyalakshmi Jul 28 '16 at 11:15
  • yes. That's exactly what I mean. =D – Fernando Gavinho Jul 28 '16 at 11:23
  • Tried adding it.But now process builder doesn't seem to work.I mean we had to manually go and approve it . – Priyalakshmi Jul 28 '16 at 11:45
0

This error is thrown when an object is attempted to be submitted for approval either because

  1. The approval process isn't activated
  2. OR your object doesn't meet the entry criteria.
  3. OR If you have selected Let the submitter choose the approver manually option under step-3 (select assigned approver ) in your approval process, then Process builder won’t work.

enter image description here

Can you confirm the 3 points mentioned are fine in your case.

  1. Yours is active from your screenshot. Okay (y)
  2. Make sure the conditions in your decision box in the process builder are the same as entry criteria i.e., the process builder should call the Approval Process only when DiscountPercent!=null && DiscountPercent>2.
  3. Make sure an approver is assigned directly in the approval process (not manual)
  • Thanks @ sfdcFanBoy, I tried adding the entry criteria as you specified still the error persist. – Priyalakshmi Jul 28 '16 at 11:17
  • I have added the screen shots of the Approval Process for your reference – Priyalakshmi Jul 28 '16 at 11:21
  • Updated answer. – sfdcFanBoy Jul 29 '16 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.