0

My lightning component is open through a visualforce page. It work fine in Chrome ,Firefox and IE web browser. But when we open this visulaforce page in mobile or in safari browser it give error message Something has gone wrong. [NoErrorObjectAvailable] TypeError: undefined is not an object (evaluating 'fn.apply')

  • 2
    Could you please share the code ? – Junaid P Khader Jul 27 '16 at 12:40
  • In the past day or two, I ran into an issue with a Lightning Component in Community Builder that was working fine, but then started to error on iOS. Try using Chrome's DevTools as emulated as iPad or iPhone and see if the issue occurs. I would also suggest trying the Salesforce Lightning Inspector to debug the issue and hopefully it helps narrow down the issue. As has already been suggested, posting your code would be beneficial in helping solving the problem. – user34828 Jul 27 '16 at 17:59
0

Q: What are the supported browsers for Lightning Experience?

A: Lightning Experience is supported with Microsoft® Internet Explorer® version 11, Apple® Safari® version 8.x on Mac OS X, and the most recent stable versions of Mozilla® Firefox® and Google Chrome™. If you’re using Microsoft® Internet Explorer® versions 7–10, you’re redirected to Salesforce Classic. The following limitations apply. You can’t access Lightning Experience in a mobile browser. Instead, we recommend using the Salesforce1 app when you’re working on a mobile device.

It is limitation for lightning component for mobile browser. User Salesforce1 App then check if it working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.