0

I have been experiencing some issues for quite a while now after I refreshed one of the organisations sandboxes. We are using soap api to push external information into salesforce, but our staging sandbox keeps getting the following error when trying to access it:

Error: INVALID_LOGIN: Invalid username, password, security token; or user locked out.

We tried to generate new passwords, security tokens many times, even new wsdl files, and I also verified that the user is not locked out, but still couldn't access salesforce though api.

Note 1: Using the same password and username though the login portal works perfectly fine.

Note 2: Everything worked fine before the refresh, and the user's profile has all access features enabled.

Would anybody know what might be causing the issue?

  • Maybe you have to whitelist the IP of the staging environment where the API is being called from? – rael_kid Jul 27 '16 at 9:39
  • but then how would you explain that the portal login works perfectly fine coming from the same ip – Marc Zaharescu Jul 27 '16 at 9:47
  • You don't need a security token to log in to Salesforce from an IP that's not listed, but you do need it if you're using the API from an IP that's not listed. – rael_kid Jul 27 '16 at 9:48
  • appearently the ip was already listed in the network access topic – Marc Zaharescu Jul 27 '16 at 10:13
  • Are you sure your API user logs in to test.salesforce.com and not login.salesforce.com? – rael_kid Jul 27 '16 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.