2

This was the exact question that someone asked long back ago on stack overflow. Account owner defaults to following sharing access levels in my org.

  1. Account Access: Full Access
  2. Contact Access: Read / Write
  3. Opportunity Access: Read Only
  4. Case Access: Read Only

The OWD for all those 4 objects are Private. can someone explaing where these access levels being defined?

  • Im seeing the same behavior and its rather surprising to me, given that all are private. I ran a full sharing rule recalculation and nothing changed. However, for me, default case access IS private, so...it must be settable - somewhere? – gorav Jun 21 '17 at 18:18
  • 1
    well this is interesting, as i change the record owner, the values for contact, opp, and case change too. So it seems like these fields reflect the sharing access granted to the owner, but also allow you to set it. spooky. – gorav Jun 21 '17 at 18:28
1

You need to navigate to Setup--> Security Controls --> Sharing Settings

enter image description here

As you are a System Administrator you are overriding all the default permissions at the OWD level. A System Administrator Can configure and customize the application. Has access to all functionality that does not require an additional license. For example, administrators cannot manage campaigns unless they also have a Marketing User license. Can manage price books and products. Can edit any quota, override forecasts, and view any forecast. Being a System Administrator you have full access to the Org

  • Do you mean that those permissions come from default OWD? They all are set to private in my org. Thanks. – sam_s Jul 26 '16 at 18:54
  • Those are not Private by default. Someone might have updated those settings in your org. – Devendra Jul 26 '16 at 18:58
  • so I just created a test account record ignoring the existing records. As per your answer, I would expect the account owner should have 'private' set to opportunity, case and contact access levels. But it doesn't, they still have the same access levels as I mentioned in the question. – sam_s Jul 26 '16 at 19:17
  • Do you have a System Administrator profile? or you might be having "Modify All Data" permission on your profile. – Devendra Jul 26 '16 at 19:19
  • Yes, I am on sys-admin profile – sam_s Jul 26 '16 at 19:24
0

Looks like this is set at the role level. Look at the role and you can set contact case and opportunity access. That is why it was changing when I changed owner.

It appears that this sharing also rolls up the hierarchy, but I need to test to confirm that this does and that role based sharing rules do not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.