1

I have created a simple visualforce page with standard controller = 'Idea'. I am able to add the VF page to page layout in a section, but when I view the page, I am not able to see the inline visualforce component. I am a system admin and I have access to VF page and there is only one page layout. I have tried creating a sample extension as well and able to add the VF page to the page layout, still the same issue. Please could you help on how to view an inline visual force page on Ideas standard layout? Many thanks.

The VF code is:

<apex:page standardController="idea">
<apex:form >
    <apex:pageBlock title="Idea Details">
            <apex:pageBlockSection title="Idea Details" columns="1">
            <apex:outputField style="width:250px" value="{!idea.title}"/>
        </apex:pageBlockSection>
    </apex:pageBlock>
</apex:form>
</apex:page>
0

Your <apex:outputField> line has a typo. You're closing the starting outputField tag before applying your style or value. Therefore, no value is being returned since the syntax is wrong.

Try changing:

<apex:outputField> style="width:250px" value="{!idea.title}">
</apex:outputField>

To:

<apex:outputField style="width:250px" value="{!idea.title}" />

OR if you want to keep a separate outputField closing tag, (which I don't think you need to in this case), you could just try fixing your typo first:

<apex:outputField style="width:250px" value="{!idea.title}">
</apex:outputField>
| improve this answer | |
  • Thank you for the reply. Sorry, that was a typo. I have modified the code now and still the same issue. – Rahul Boinepally Jul 25 '16 at 12:49
0

See Idea Issue

This might be the issue with customization for Idea object.

| improve this answer | |
  • Thank you, but that is to do with overriding the button, but I want to add the inline VF to the standard page layout. As you said, it may be related to same issue as well. We have enabled IdeaStandardExtension methods to our org too. – Rahul Boinepally Jul 25 '16 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.