11

Not sure if this is a bug in the Developer Console...?

I am building some simple test classes that reference static methods in a managed package. Everything works great when I build and update the code via the standard Apex Class UI. But if I open the same, working test class in the Dev Console, make any update and try to save it, I get an error saying the class in the managed package is not visible, and it won't let me save it.

Package Visibility: Type is not visible xxx

But I can go back to the UI, update and save it there, and the tests runs without issue.

What am I missing?

  • 1
    Case Raised: 09411115 – BritishBoyinDC Jun 26 '13 at 21:34
  • Sadly these bugs do not instill faith in the developer console - back to using Eclipse - would you have a link to the case? – Daniel Sokolowski Feb 27 '14 at 2:07
  • Hi BritishBoyinDC, I can see you raised a case but I really don't know how/where to check for that case's status/response. Is there any way you can give me some instructions or just let me know what they said? I just had the same problem from MavensMate. – Jose Nov 17 '15 at 18:19
  • They couldn't replicate in another org, so though they could in that org, so they determined it was just a blip in that org. I think I just updated via UI editor, and once it was saved it worked ok moving forward... – BritishBoyinDC Nov 20 '15 at 16:16
3

I don't think you are missing anything. This almost certainly seems like a bug with the Developer Console.

I just tried to replicate the issue myself and got the same error message, I believe you will need to log a case with Saleforce.

The fact that you are able to do these changes in the class editor makes me sure it isn't any of these things, but for completeness though, here are some easy mistakes:

  • Is the class in the Managed Package global?
  • Is the static method in the class in the Managed Package global?
  • Are you using the Manged Package namespace correctly in the code referencing the Managed Package?
| improve this answer | |
  • Yeah - I checked all those several times as I thought I was going crazy...it is definitely visible in the class definition, and works just fine when executed via the normal UI...I'll try again today, and it is still an issue, raise a case...thanks for confirming the issue for me! – BritishBoyinDC Jun 25 '13 at 18:00
  • per @daveespo, looks like the dev console may have fallen prey to a gotcha with the tooling api, and just isn't setting the versions for the related managed packages, which makes sense considering there isn't any place you can set this in the UI, however this seems to get interpreted as setting the managed package version to null and the current package version are ignored, see salesforce.stackexchange.com/a/20829/594 – Ralph Callaway Nov 1 '14 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.