0

I am using Ant migration tool to deploy some custom objects from one org ro another. Below is my package.xml:

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>Candidate__c</members>
        <members>Interview__c</members>
        <members>Interviewer__c</members>
        <members>Job_Application__c</members>
        <members>SFDC_Job_Opening__c</members>
        <members>Job_Opening_Skill__c</members>
        <members>Job_Opening_Skill_Profile__c</members>
    </types>
    <version>37.0</version>
</Package>

I used this link - [http://www.sfdcpoint.com/salesforce/migration-using-ant-in-salesforce/][1]

[1]: http://www.sfdcpoint.com/salesforce/migration-using-ant-in-salesforce/ for my reference to do the migration. I was able to retrieve the package with no errors and I get build successful without any errors. Also, I was able to deploy the package to the target org without any errors.

deployUnpackaged:
[sf:deploy] Request for a deploy submitted successfully.
[sf:deploy] Request ID for the current deploy task: 0Af360000131pmOCAQ
[sf:deploy] Waiting for server to finish processing the request...
[sf:deploy] Request Status: Succeeded
[sf:deploy] *********** DEPLOYMENT SUCCEEDED ***********
[sf:deploy] Finished request 0Af360000131pmOCAQ successfully.

BUILD SUCCESSFUL
Total time: 5 seconds

But when I check my target org I don't see any of the custom object created. What could possibly have gone wrong?

  • 1
    you've missed <name>CustomObject</name>, between types and members – Ilya Lepesh Jul 18 '16 at 5:50
2

You've missed <name>CustomObject</name>, between types and members

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>Candidate__c</members>
        <members>Interview__c</members>
        <members>Interviewer__c</members>
        <members>Job_Application__c</members>
        <members>SFDC_Job_Opening__c</members>
        <members>Job_Opening_Skill__c</members>
        <members>Job_Opening_Skill_Profile__c</members>
        <name>CustomObject</name>
    </types>
    <version>37.0</version>
</Package>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.