2

I'm including a VF page into an standard page layout. This error is appearing:

Your browser privacy settings have prevented this page from showing some Visualforce content.

enter image description here

After "googled" it, this is the Salesforce recommendation:

If your browser is set to block third-party cookies, and it does not use the P3P header, and you see an error similar to the one above, perform one of the following actions:

  1. Configure P3P for your browser
  2. Change your browser settings to allow third-party cookies
  3. Add the appropriate server to your browser's cookies exception list

The problem is that I have not control over final users browser configurations.

Is there any alternative approach like window.domain = '*.force.com' ??

1

This is a bit off the cuff, but try setting the P3P response header for the Visualforce page to override their default value ("CUR STA OTR").

Apexpages.currentPage().getHeaders().put('p3p', 'CP="CAO DSP IVAa IVDa OUR BUS UNI OTC"')

Note:

  1. I'm not certain that this will actually update the response headers or just update the request headers.
  2. The values I've added above have worked for me in the past but I can't recall what they are asserting. It would pay to check them.

Alternatively, are you explicitly calling setCookies on the pageReference in the controller for the Visualforce page? If so, try setting this cookie elsewhere (easier said than done).

| improve this answer | |
  • Thx Daniel. I'll try to implement this and tell you how its works – Martin Borthiry Jun 25 '13 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.