13

Whenever one of my end users clicks "Export Details" or "Printable View" on a report and chooses .xls (default), the report will download. When she clicks on it to open, Excel opens but the area where the report should be is blank and gray. This happens will all Salesforce reports she exports. Exporting to .csv is working just fine. Also to note, she has Windows 7 Professional and Microsoft Excel 2010.

I logged in as her from my laptop and was unable to replicate the issue as everything worked fine for me. We did a screensharing session and I logged in as myself on her computer, but we still encountered the issue.

Any other .xls files are opening just fine for her in Excel. She mentioned she did a Windows update yesterday and that might have something to do with it. It's just curious that it's only happening with Salesforce reports.

Has anybody else encountered this issue? Do you think this is more of a laptop problem or a Salesforce problem?

  • 1
    Try having her just save as -> .xls or .xlsx. It actually exports an html file. – Adrian Larson Jul 14 '16 at 14:56
  • 1
    this is a laptop problem, if you say csv is working why not have them use that instead? – Dan Wooding Jul 14 '16 at 15:15
  • 1
    This is definitely a laptop issue, the SFDC export is an HTML file with file name suffixed by .xls. Excel is clever enough to be able to open HTML files and coerce into a spreadsheet in memory. If the export file is big, Excel may run out of memory to convert from HTML to a spreadsheet. CSV is much more compact and hence easy to open. – cropredy Jul 14 '16 at 16:00
  • Contacted Salesforce Support and this is the article they gave for a temp fix: support.microsoft.com/en-us/kb/2994633. They also said "R&D team has investigated this matter and logged a New Issue for it to be repaired. Unfortunately, I cannot provide a timeline as to when this repair will be implemented due to Safe Harbor constraints." – Piya Fiedler Jul 14 '16 at 16:45
  • We've had similar problems with other applications. By adding the affected sites to our trusted sites internet zone and re-exporting files the issue's removed. The problem is related to trusts; specifically the downloaded file's ADS Zone Identifier flag saying that the file's from an insecure source. More on that flag here: stackoverflow.com/questions/6374673/… – JohnLBevan Jul 18 '16 at 10:42
11

We experienced the same issue and found a workaround that works for us. Right click the excel file you downloaded, click on properties. On that screen hit the "unblock" button and then hit apply. You should be able to open the file now.

enter image description here

10

Is KB3115322 (Security Update for Excel 2010) installed? If so, uninstalling this update worked for us. I notified Salesforce about the problem so that either Salesforce or Microsoft fixes the issue, since the update is flagged as critical by Microsoft.

It's KB3115262 related to Excel 2013. It's KB3115272 related to Excel 2016.

  • We uninstalled KB3115130 (Excel 2010) and it fixed our problem. Mine isn't even with salesforce, my custom ASP.NET code is now "broken" all over the place because of this damn update. – Taylor Brown Jul 19 '16 at 14:50
8

I contacted Salesforce's Support team and they provided this article as a temporary fix.

They also mentioned:

"Our R&D team has investigated this matter and logged a New Issue for it to be repaired. Unfortunately, I cannot provide a timeline as to when this repair will be implemented due to Safe Harbor constraints."

Salesforce Known Issue

  • 1
    Did they provide you with a link to the new issue? Could you edit it into your answer? – battery.cord Jul 18 '16 at 14:32
  • You should probably accept this or another answer since it sounds like your issue has been resolved. – Adrian Larson Jul 20 '16 at 15:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.