2

I have a custom VFP with few validations on it and when the user submit the page it run through validations and display any errors (if any)

But the problem I'm having is that whenever there are some validations error on the page then I'm unable to open the outputlink otherwise I do not have any issue with opening/clicking the link and open the page.

Visualforce page:

   <apex:pageBlockTable Title="Employees" value="{!Employees}" var="item">
     <apex:column headerValue="Name" >
       <apex:outputLink value="{!URLFOR($Action.Employee__c.View, item.empId)}">{!item.Name}</apex:outputLink>
     </apex:column>
  </apex:pageBlockTable>

What might be the issue that triggers not to open the URLFOR page?

What happens when you click on the link:

When click on the link, I see white page with nothing on it and the url i see is this https://..../apex/employeeView?id=a004B000001gDiA&sfdc.override=1

Screen shot of my View button/link. showing that its standard sf page:

enter image description here

  • can you change the outputlink to a commandlink? if so you can try using immediate attribute developer.salesforce.com/docs/atlas.en-us.pages.meta/pages/… – Rao Jul 11 '16 at 18:29
  • Sounds like your EmployeeView page is messed up and it has nothing to do with the markup you have posted. Just my two cents. – Adrian Larson Jul 11 '16 at 18:50
  • @AdrianLarson: EmployeeView is a standard page layout if the page is messed up then it should not open before validation error throws an error. – Nick Kahn Jul 11 '16 at 18:53
  • No, you have clearly implemented an override on the View action. Go to Buttons, Links, and Actions on the Employee__c object and clear it out to see the difference for yourself. – Adrian Larson Jul 11 '16 at 18:54
  • I'm not overriding the view page, View - Standard Salesforce.com Page – Nick Kahn Jul 11 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.