1

We have built microsite page.mycompany.com, when we try to access this site using HTTPS we get error for certificate net::ERR_CERT_COMMON_NAME_INVALID The certificate is issued for *.s6.exacttaget.com

1

Personalized URLs are not HTTPS unless you work with SFMC to configure an SSL certificate.

You can, however, use the base SFMC landing page URL with HTTPS -- with the same QS parameter:

https://pages.exacttarget.com/page.aspx?QS=YOURPAGESPARAMETERHERE
  • Thanks @Adam-Springs , contacted SMC support and account exec. – Nikhil Walvekar Jul 7 '16 at 17:05
1

We had this problem too - we had to contact our account manager to purchase new SSL certificates, and also get the option to create HTTPS:// pages in CloudPages activated on our account (it is not available by default).

-1

At first, try using in URL as "https://page.mycompany.com", it will asking for validation of certificate still it should take you to your site. Moreover if you enter the Certificate in Certificate and Key management signed by one of the trusted CA provider by salesforce into the domain created in salesforce then , salesforce will authenticate your microsite and take you to that page.

  • I believe that is specific to Salesforce core, not Marketing Cloud. For Marketing Cloud, if an SSL certificate needs to be configured for the private domain being used for the account then an additional purchase is required. A client can contact their AE in order to get this. – Mac Jul 7 '16 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.