When I try to upload an email to Salesforce it is automatically added to a contact profile of a colleague in my company. Would you please advise how to fix this in order to see the emails in my unresolved items and link them to the correlated Account record?

1 Answer 1


This is a default feature of 'Salesforce for Outlook'. You can control and customise this behaviour based on your preferences to disable it altogether or define rules - read more here.

enter image description here

Additionally, you can also define handling for items which are not resolved by Salesforce by default.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .