1
  1. I have created a managed package "SamplePack" in my developer edition "Dev1".
  2. SamplePack is installed in another developer edition "Dev2", It's working fine too.
  3. Now i Uninstalled SamplePack from "Dev2". Again I'm trying to re install same package into "Dev2".
  4. It's throwing an error "This app can't be installed. Package Not Found: "The requested package doesn't exist or has been deleted. Please contact package publisher"

What actually stopping to re install SamplePack Managed package

or

Can't we re install a manged Package Once we Uninstalled

  • If the destination org is on a different pod than the packaging org and you tried to install soon after creating the package, it may not have propagated to all the pods yet. Wait a little bit and try it again. Could also be that you copied the installation URL incorrectly? – Eric Jun 30 '16 at 4:55
0

The error seems to suggest me that ,your Publisher org has depreciated the package or deleted .

Because this error only pops if you no longer have the package in your Publisher org .

And to answer we can certainly uninstall and install managed packages as many times as we need .

  • Thank you for reply @Mohith I forgot to mention One point, i.e.., the same package able to install in new Developer edition for first time. It means Package exists I hope soo. AND more over depricate button disabled for that package version. – Rock SFDC Jun 30 '16 at 4:45
  • This seems timing issue .Also can you try with different browser and some delay like half an hour – Mohith Shrivastava Jun 30 '16 at 4:59
  • I have tried to install yesterday, error came. I'm trying today also getting the same error. – Rock SFDC Jun 30 '16 at 5:07
  • Sounds like you will need support case on this . Thanks – Mohith Shrivastava Jun 30 '16 at 5:08
0

Check if package is managed-release or managed-beta. managed-beta package cannot be upgraded.

  • The user is installing and uninstalling the app not upgrading – Mohith Shrivastava Jun 30 '16 at 4:46
  • i..e.., ** managed-release**. and I'm not upgrading the package. I have Uninstalled the package and trying to re install the same package there I'm getting above error – Rock SFDC Jun 30 '16 at 4:54
  • Exactly @Mohith, The user is uninstalling and installing the app not upgrading – Rock SFDC Jun 30 '16 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.