1

We are getting below error while connecting from Informatica. What is the workaround to solve the problem? Did anyone face the issue.

Error while calling web service operation: login, error was:

[UnexpectedErrorFault [ApiFault exceptionCode='UNSUPPORTED_CLIENT' exceptionMessage='TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.']]

5

As per Informatica there should not be any issue. The fix is applied behind the scene. You should raise a support ticket with Informatica. Please see the below link.

https://network.informatica.com/thread/55458

Am I impacted?

If you use Informatica Cloud to connect to Salesforce, you are impacted.

Behind the scenes, Informatica will support TLS 1.1 and TLS 1.2 so that there is no impact to your ability to access Salesforce service with inbound and outbound connections.

How do I install the patch or resolve the issue?

A patch is not required. Informatica will programmatically update your existing Salesforce connections to support TLS 1.1 and TLS 1.2 encryption protocol.

1
  1. I am getting the same problem when I tried to access salesforce through Eclipse. Problem was that I use JDK 7 but now JDK 8 is required for salesforce. After installing jdk8 and configure with eclipse, problem was resolved.

I am not sure that this is a case with you, but might be it helps you.

  1. In some orgs, there is a feature to deactivate the TLS1.0. For that, you need to go Setup -> Critical Update -> Deactivate TLS1.0.

use below link for more details:

https://help.salesforce.com/apex/HTViewSolution?id=000221207

Please refer below screenshot, in which it mentioned that on sandbox it disabled from june 2016.

enter image description here

Hope it helps you :)

  • Hi Anurag, I am actually trying to connect from Informatica, I can not change the version on fly. Any workaround to fix the issue with minimal changes? – Rajashekar Burugupally Jun 28 '16 at 9:20
  • You can try the link which I now added in the answer, may be there is some browser problem with you. – Anurag Bhardwaj Jun 28 '16 at 9:22
  • I don't think this helps the OP at all. Looking at the error message, he's connecting using TLS1.0, so enabling the critical update to Deactivate TLS 1.0 is not going to help him. – mkorman Jun 28 '16 at 10:57
  • @mkorman: He was trying to access the sandbox. My comment is only to highlight that now salesforce stop this feature. May be his problem with informatica. Thanks for your suggestion. – Anurag Bhardwaj Jun 28 '16 at 12:50
1

Install EBF443385 for both server and powercenter client.

0

I think you'll need to configure Informatica to change how their product is connecting to SalesForce. If you are hosting it yourself, perhaps there is some configuration to specify how it connects. Otherwise, you will need to raise a support case with them.

0

Adding some points to Anurag's Answer.

 1) Salesforce has implemented this constraint on all 
     Sandboxes so you CANNOT deactivate it fronm UI 
 2) To fix this, go to the URL given by Anurag and download the 
    registry from the link given in the description and install the registry 
 3) Restart the machine and the error will not be there
0

Salesforce recently disabled TLS 1.0 so they no longer accept incoming connections using that protocol. You must use TLS 1.1 or 1.2.

This was initially rolled out as an optional security patch, but it was made manadatory recently (so there is no way to disable it).

How to fix it? Your integration (in this case Informatica) needs to update to use TLS 1.1 or 1.2. I must admit that I don't know that application at all.

As mentioned above by @Saroj Bera, your best bet is to open a ticket with Informatica.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.