1

Very straightforward. Works without LockerService, doesn't work with LockerService.

EDIT : It seems to be less broken in Sandbox, which is on Version 10 of Summer '16, compared to Version 9.5 of Summer '16 but definitely still broken.

TestApp2.app

<aura:application >
  <ltng:require scripts="{!$Resource.jquery}"/>
    <div aura:id="testdiv" id="testElem">  
        Visibility test.
    </div>
    <ui:button buttonTitle="Test button" class="button" label="Test" press="{!c.toggle}"/>
</aura:application>

TestApp2Controller.js

({
    toggle : function(component, event, helper) {
        $("#testElem").slideToggle("slow");
    }
})
  • Jason, which version of jQuery are you using? – JF Paradis Jun 24 '16 at 20:42
  • @JFParadis I am using JQuery 2.2.4 – Jason Lee Jun 24 '16 at 20:55
0

Works for me on Locker in my sandbox, sort of. The text slides away and comes back on one single button press but this is definitely more than you're getting in Locker. Is this in a sandbox, a dev edition org, or production? Sandboxes are all on Summer '16 Patch 10 while most other orgs are still on Patch 9.5. So try in a sandbox or wait for Patch 10 and try again, then debug if it's still not behaving how you want it to. If this is actively affecting a production org then disable Locker on it until it's patched.

  • This is on a dev org, I guess I'll try it out in a sandbox, thanks! Also, where could I find information about which orgs are on which patch? – Jason Lee Jun 24 '16 at 17:54
  • 1
    There is info here: trust.salesforce.com/trust/instances where after you click on an instance name, the patch level is visible in the upper right of the screen beside the RSS icon. – Charles T Jun 24 '16 at 17:56
  • Now that I test it in a sandbox org, I am getting the same result you are getting. Still seems like unintended behavior though.. – Jason Lee Jun 24 '16 at 18:00
  • Indeed... but if you can report the new results now, they'll be able to judge what might still need to be fixed in the next patch. – Charles T Jun 24 '16 at 18:45
  • Looks like both sandboxes and production are now up to Patch 10.3. – Charles T Jun 28 '16 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.