1

I am trying to deploy some profiles to an environment but it is failing. The error states In field: application - no CustomApplication named standard__DataAssessment found. The metadata entry is included below. This is not actually a custom application but I cannot figure out what configuration it refers to.

<applicationVisibilities>
    <application>standard__DataAssessment</application>
    <default>false</default>
    <visible>true</visible>
</applicationVisibilities>

Note: Both environments are on Summer 16. Both environments have the same Packages installed.

1 Answer 1

1

It refers to an Application deployed in a managed package that must have been installed in the org at some point. standard__ is the namespace and DataAssessment the App.

4
  • Thanks for the reply. I confirmed that both the source and destination environments have the same packages installed which makes the error even more confusing. Jun 21, 2016 at 15:24
  • How are you deploying? Is it referenced in packages.xml? If so, can you just remove it since the package can't be installed.... Jun 21, 2016 at 18:14
  • It's referenced in Profiles. I will have to remove the xml entries from the Profiles going forward but we have a strict deploy process that does not make it easy to make these changes on the fly. We are deploying using Ant/Jenkins. Jun 21, 2016 at 21:02
  • did you managed to fix this? i am encountering this post upgrade to winter 18 and trying to metadata from summer
    – OK999
    Sep 14, 2017 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.