I created a VF page, configured to be public under the Partner Site.

When I am not logged in anywhere, I get the page fine.

When I logged in Partner Site with some partner contact, I get the page fine.

When I logged in force.com (internal users), I get the page fine.

But, when I am logged in another Force.com Site (say for my Customers) with a customer contact, the page is not opening - I am redirected to the login page of the Partner Site.

When I am logged in Customer Portal and browse a public page of Partner Site, I want / am expecting to see the page, as a guest, because I am not logged in Partner Site. How can I make this scenario happen?

Note: I tried the other way around (public page in customer site, me logged in partner site) and got the same 401/login page response.

Both Sites are Communities having Administration/Template=Salesforce Tabs + Visualforce

  • Are both of these SFDC Communities? Are you using Templates (Napili, etc.) or VF+Tabs?
    – Jason
    Jun 16, 2016 at 21:35
  • Yes both are SFDC Communities, both showing Administration/Settings/Template = Salesforce Tabs + Visualforce Jun 17, 2016 at 11:28

1 Answer 1


No You need to add in your partner user's profile to access it there. Salesforce has different security permission at different level. You need to give permission at all level.

So just go to their profile and scroll down and you will see a section Visualforce page and add your page there.

  • ==> same issue 1.I added every possible profiles to my vfpage (Enable Profile Access for Visualforce Page). 2.logout / closed all my browser 3.logged as Customer contact to Customer Site 4.browse my public page in Partner Site Jun 16, 2016 at 17:19
  • @Jean-PierreDery I think because you are logged in in same browser then SF might accesing same cookies to access another site and then it is giving you this error. Try to access some other public page Jun 16, 2016 at 17:29
  • So you are thinking a Salesforce limitation? Jun 16, 2016 at 19:43
  • @Jean-PierreDery not 100% sure but yes. Jun 17, 2016 at 2:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .