We have a community site, and we don't want it to be rendered to Salesforce1.

When opening the site in mobile browsers and users logged in for the first time (or logged out without switching in to Full site, logged-in again), users are redirected to "domain/community/one/one.app"

I know users can do "= -> Full site" but that creates confusion. We have published a "How-to" but still, we are receiving numerous ticket about it.

Is there anyway to disable Salesforce1 or force fullsite by default?

Note 1: "Salesforce1 User" is not checked in user records, but Salesforce still redirects user to "/one/one.app"

Note 2: We are also no using Salesforce1 app

Note 3: We don't intend to disable Salesforce1 in our entire org, in just one of our communities or specific page.


  • Yeah pretty sure it's not possible to toggle with any sort of granularity.
    – Adrian Larson
    Commented Jun 27, 2016 at 19:14

1 Answer 1


Take a look at Defining Which Users Can Use Salesforce1.

You can control whether users can access the Salesforce1 mobile browser app when they log in to Salesforce from a supported mobile browser. By default, the mobile browser app is turned on for your organization.

  1. From Setup, enter Salesforce1 Settings in the Quick Find box, then select Salesforce1 Settings.
  2. Select Enable the Salesforce1 mobile browser app to allow all users in your organization to access the app. Deselect this option to turn off access to the app.
  3. Click Save.

So make sure the checkbox is false for Enable the Salesforce1 mobile browser app.

  • i apologize, i should have been clearer with my query. we don't intend to disable the whole salesforce1 in our org. just in one community
    – pnoytechie
    Commented Jun 14, 2016 at 15:47
  • Unfortunately, I think it's all or none. You might be able to get your account executive to set it up specific to a community.
    – Adrian Larson
    Commented Jun 14, 2016 at 16:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .