3

I'm trying to rename a managed package custom object's related list label through the Translation workbench using this article as a guide.

When selecting "English" as the language and the Setup Component as "Custom Field", my custom object, Payment Type, does not appear in the Object dropdown.

English translation

enter image description here




When I change the language to Spanish, however, it does.

enter image description here

enter image description here

The object is in a master-detail relationship which may be relevant.

3

For custom objects that are part of a Managed Package this is done slightly different, because you have to override the values provided in the package:

  1. Click Setup->Translation Workbench->Override
  2. In the override screen, select the Managed Package that contains the field you want to relabel
  3. Pick the Component that you want to relabel (in this case, Custom Field)
  4. Pick the object that contains the field
  5. Pick "Field Label" (or whichever aspect you want to override)
  6. The rest is same as 'normal' fields

The reason that you only have to do this for 'English' is that the Managed Package's language is probably English and thus they have provided only the labels for that 1 language. So only 1 set of labels to override.

  • Thanks @Guy. One change though - as I was looking for the related list label - so the option I would choose for Aspect is "Related List Label". – SineadCoyle Jun 14 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.