0

I tried to upload a CSV file through Data loader without date field but still I am getting below error message:

"Error converting value to correct data type: Failed to parse date: Yes"

Please help me to resolve the issue.

  • It sounds like you are mapping from a field in the CSV which contains the value "Yes" to a field in Salesforce which is of type date. Check your mapping (.SDL) file is correct. – Doug B Jun 9 '16 at 13:11
3

You should check your csv carefully. It seems that there's YES value instead of date value.

Also be sure that your date format is accaptable for salesforce. ( you can set your date format below screenshot setting) If you check this checkbox, date format should be like dd/MM/yyyy and dd/MM/yyyy HH:mm:ss.

Apex Data Loader -> Settings -> Use European date format ApexDataLoader-Settings

  • I have check. Everything is up to mark but still getting error – Russel baker 1 Jun 12 '16 at 5:58
1

You have to manually change format of Date in your CSV file.

Your Date must be in this format enter image description here

As of this Knowledge Article

"Date" field acceptable formats

YYYY-MM-DD
YYYY-MM-DD hh:mm:ss
YYYY-MM-DD hh:mm:ss
YYYY-MM-DDThh:mm:ssZ
YYYY-MM-DDThh:mm:ss.sssZ

"Date Time" field acceptable formats

YYYY-MM-DD hh:mm:ss
YYYY-MM-DDThh:mm:ssZ
YYYY-MM-DDThh:mm:ss.sssZ

And from this Data Loader Guide

Recommended Date Formats is yyyy-MM-ddTHH:mm:ss.SSS+/-HHmm:

yyyy is the four-digit year
MM is the two-digit month (01-12)
dd is the two-digit day (01-31)
HH is the two-digit hour (00-23)
mm is the two-digit minute (00-59)
ss is the two-digit seconds (00-59)
SSS is the three-digit milliseconds (000-999)
+/-HHmm is the Zulu (UTC) time zone offset

The following date formats are also supported:

yyyy-MM-dd'T'HH:mm:ss.SSS'Z'
yyyy-MM-dd'T'HH:mm:ss.SSS Pacific Standard Time
yyyy-MM-dd'T'HH:mm:ss.SSSPacific Standard Time
yyyy-MM-dd'T'HH:mm:ss.SSS PST
yyyy-MM-dd'T'HH:mm:ss.SSSPST
yyyy-MM-dd'T'HH:mm:ss.SSS GMT-08:00
yyyy-MM-dd'T'HH:mm:ss.SSSGMT-08:00
yyyy-MM-dd'T'HH:mm:ss.SSS -800
yyyy-MM-dd'T'HH:mm:ss.SSS-800
yyyy-MM-dd'T'HH:mm:ss
yyyy-MM-dd HH:mm:ss
yyyyMMdd'T'HH:mm:ss
yyyy-MM-dd
MM/dd/yyyy HH:mm:ss
MM/dd/yyyy
yyyyMMdd

Note the following tips for date formats:

  1. To enable date formats that begin with the day rather than the month, select the Use European date format box in the Settings dialog. European date formats are dd/MM/yyyy and dd/MM/yyyy HH:mm:ss.
  2. If your computer's locale is east of Greenwich Mean Time (GMT), we recommend that you change your computer setting to GMT in order to avoid date adjustments when inserting or updating records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.