1

I'm new to using Eclipse and the force.com ide. I seem to be able to edit my classes sync them and save them both to my sandbox and production. But when I create a new class using Eclipse and go through the motions to save it to my sandbox "Save to Server" it appears to work properly. Even in salesforce when I go to deployment status is says one object deployed successfully. But I cannot find it in salesforce and does not appear to be there.

  • Have you gone to the users permissions and made sure the relevant profiles can see the object including System Administrator? – Dave Humm Jun 8 '16 at 18:04
  • I just looked and it's not in either list available or enabled. I notice in Eclipse under warnings it is specifically saying "Offline Mode. File only saved locally, not to server" even though the sandbox server is saying the deployment was successful it does not appear to be there. I cannot see how to change the file from offline mode – Ohmicron Jun 8 '16 at 18:16
  • You force save to server and it's still local only? Are you able to create it in dev console? – Adrian Larson Jun 8 '16 at 18:24
  • offline mode to online mode toggle: RMB Project in Eclipse and then select Force.com | Work Off(on)Line – cropredy Jun 8 '16 at 18:26
  • @cropredy that was the magic it needed right there. I was thinking I needed to put the new class itself in an online mode not the whole project. If you change your comment to an answer I will check it so you get credit – Ohmicron Jun 8 '16 at 18:40
2

To turn Eclipse Force.com IDE project from offline to online:

  • Right Mouse Button the Project
  • Choose Force.com | Work Online

Repeat process to work offline

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.