1

I am using the Lightning interface and have created a Canvas app and a VisualForce page to show it. When I view the page, my external URL receives two parameters:

_sfdc_canvas_auth: user_approval_required
loginUrl: https://login.salesforce.com/

I was expecting to receive a signed_request parameter which I can test my secret against.

Having searched around I've found this occurrs when the "Permitted Users" is set to "All users may self-authorize", whereas it seems I need to set it to "Admin approved users are pre-authorized" so that users don't need to approve it. Where can I set this? Or is this the wrong solution?

  • 1
    you have to go to setup->connected app->then edit your app.There you will find this setting. – Mr.Frodo Jun 8 '16 at 16:18
  • @Mr.Frodo which section is it in, what is it called? I can't see it on the edit app page...... – user33250 Jun 8 '16 at 16:52
  • in classic you can find that way. in lightning i'm still finding ;) – Mr.Frodo Jun 8 '16 at 17:06
  • glad you did that.now you can mark it right as well. – Mr.Frodo Jun 8 '16 at 17:22
1

It appears there is another edit app page, and this is where the setting can be found. Go to Setup then search "connected" in the search box, then click Manage Connected Apps, then click edit on the target app. Find the Permitted Users setting and set accordingly.

After that, do the same but click the app name instead of edit, then click Manage Profiles, and select the desired profiles or all of them.

Now, Salesforce will send signed_request to the external page.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.