3

I started my Force.com IDE and go an error message saying unable to load metadata for one of my class. I did a refresh and everything disappeared. I then tried creating a new project, and got following error.enter image description here

I haven't changed my password and I am able to login using my current credentials.

Not sure how to fix this.

I have even tried re-installing the IDE but same error.

  • Are you using your security token? And you haven't confused your sandbox/production logins? – Mike Chale Jun 8 '13 at 18:25
  • Can you connect using same credentials on login.salesforce.com? Did you set the security token ? – Martin Borthiry Jun 8 '13 at 22:11
  • 4
    What do you mean "everything disappeared"? Maybe eclipse doesn't see the projects (or somehow "plugins" directory got corrupted) but check on the filesystem whether your projects are in directory called workspace? If they physically are there you'd just have to reimport them to IDE (maybe make backup first). Other than that - looks like sec. token problem but check also .log file in eclipse... – eyescream Jun 8 '13 at 22:31
  • I did a reimport and it worked like a charm. Thanks!!! – Yash Mehta Jun 9 '13 at 7:33
1

I kind of figured out why this happened. My machine was running on JDK 7, I did an uninstall of JDK 7 and installed JDK 6. Force.com IDE is working fine now.

  • Cool, glad my comment could be of assistance :) Please consider marking answer as accepted so it goes "off the radar" and improves our stats! – eyescream Jun 10 '13 at 21:59
  • This is a good answer. JDK7 is problematic indeed, but is not obvious to developers to uninstall JDF7 and install JDK6. – Shumon Saha Jul 4 '13 at 14:28
0

Maybe some metadata which once existed do not exist any more. Here is the simplest way to solve most Eclipse problems, although it is extremely crude and time consuming in case the project contents have a lot to be downloaded.

  1. Make a backup Ctrl + C of your code/files from the Workspace and store/save/paste Ctrl + V the code in a different folder using Windows Explorer.
  2. Delete your Workspace using Windows Explorer.
  3. Recreate/download/import the project again using Eclipse / Force.com IDE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.