2

I created a new record type in a sandbox. Then I moved the record type over to production, and no one can create a record with that record type.

In setup>opportunities>record types, both are active,

I can't figure out how to enable this. I can set page layout assignments. I can make the field visible on the page layout. But I can't create or edit an opportunity to this record type, I think because the record type is not enabled for any of my users.

I think I can create a new permission set, but this just seems like the wrong way to do it.

5

You can follow below steps if Record Type is already moved without profile settings:

  1. Go To Setup-> Manage Users-> Profiles
  2. Open appropriate profile/profiles which should have access to new Record Type.
  3. Go To Record Type setting section and click edit near the object to which new Record Type belong.
  4. You can now choose Record Type available for this profile.
  5. Once you setup new Record type in available record types of the Profile, user belonging to profile will have access to create record of this record type.
4

Make sure you include all profiles when you deploy the RecordType. Click the Add Profiles button on your Outbound Change Set and select all.

Add Profiles Button Screenshot

  • Do you know if there is a way to change it in production after the fact? – denvergreene Jun 3 '16 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.