2

http://pages.exacttarget.com/michigan-thank-you/?errorcode=10&errorcontrol=5089212

I am presented with the above URL when I attempt to add a new subcriber to ExactTarget via WebControl form.

the following is the excerpt of the code

<form action="http://cl.exct.net/subscribe.aspx?lid=5089234"
<name="subscribeForm" method="post"> <input type="hidden" name="thx"
<value="http://pages.exacttarget.com/michigan-thank-you/" /> 
<input type="hidden" name="err"
<value="http://pages.exacttarget.com/michigan-thank-you/" /> 
<input type="hidden" name="usub"
<value="http://pages.exacttarget.com/michigan-thank-you/" />
<input type="hidden" name="MID" value="10904666" />
<table cellpadding="0"cellspacing="0" border="0">
<tr>
    <td><font face="Verdana" size="2">FName:</font></td>
        <td><input type="text" name="First Name" /></td>
</tr>

<tr>
    <td><font face="Verdana" size="2">Email:</font></td>
    <td><input type="text" name="Email Address" /></td>
</tr>

Per Profile Management, the only required field is Email Address. The errorcontrol value being returned is the List ID that I'm trying to add a member to. The list in question is empty (no members) The ET Help documenation only covers errorcode=10 with a blank errorcontrol (in my case I'm getting returned the List ID.

I just don't know why I cannot add new member to an 'empty' list.

Any thoughts would be appreciated.

0

What the above excerpt did not show was that the hidden input control for MID was listed twice in the text. Once the duplication was removed the post worked fine. Thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.