5

I have setup a Salesforce community and selected System Administrator to login to a community.

enter image description here

I am not able to login with any Admin user but all my community users work. When I look at the login history I see I see:

No community access

What do I need to do to enable Admin users to get community access?

5
  • How are admin users login in ? Commented Jun 2, 2016 at 23:46
  • Through a custom visualforce page. that calls Site.login(username, password, startUrl); Commented Jun 3, 2016 at 0:10
  • For employee login or admin,I don't think site.login will work .On login page usually there is a different link for employees and admin go through different route Commented Jun 3, 2016 at 0:14
  • 1
    @MohithShrivastava ok what controller command do I need to use to login admins or employees? Commented Jun 3, 2016 at 0:17
  • @ThysMichels did you managed to find a solution for your problem? Just have the same exact issue.. Commented Dec 16, 2019 at 19:59

2 Answers 2

2

You will need to drop a link on your Site Page which will have a label to help employees Log in via that .SFDC labels as "If you are Employee Log in here" .

The URL for this login will look like below

https://login.salesforce.com/?ec=302&startURL=/servlet/networks/session/create?site=0DME0000000fxWx&inst=E

Now if you notice the site param has an Id there attached .You will need to get your site Id from going to Sites in Set up menu and inspect element on chrome browser or other browser to get the Site Id .

You can also query for this Id .I will recommend to use labels so you can configure each time .

Also you will need to encode the StartURL parameter (URLENCODE).

2
  • What does inst parameter do? Please refer to my question... salesforce.stackexchange.com/questions/157481/… Commented Jan 25, 2017 at 22:11
  • This no longer correct. Not sure if it was at the time in 2016, but Salesforce has a setting for this where don't have to do a crazy URL parameter. (Clever trick though...)
    – rmarq423
    Commented Nov 17, 2023 at 17:27
1

This can be achieved by going to Experience Cloud Workspace and under Login & Registration, checking 'Allow employees to log in directly to an Experience Cloud site'

That other answer should be changed. But I have to give credit to a clever solution to add the session site switch parameter under &startURL=

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .