0

I have created a community with all the default pages (login, logout etc.). But my login page is not showing up. Below is my community URL -

https://commsbx-i3vision.cs43.force.com/SupportCommunity

What am I missing? Below is my log in controller -

global with sharing class CommunitiesLoginController {
global CommunitiesLoginController () {}

// Code we will invoke on page load.
global PageReference forwardToAuthPage() {
    String startUrl = System.currentPageReference().getParameters().get('startURL');
    String displayType = System.currentPageReference().getParameters().get('display');
    return Network.forwardToAuthPage(startUrl, displayType);
}
  }
3
  • Have you edited your log-in controller?
    – crmprogdev
    Jun 2 '16 at 13:19
  • I updated my question with log in controller. haven't edited it
    – Maneesh
    Jun 2 '16 at 13:21
  • I resolved this. The problem was with the CommunityLandingPage. It was showing as modified. I reverted the changes and it started working. Thanks everyone for all the inputs!
    – Maneesh
    Jun 3 '16 at 13:03
1

In your site settings you will need to specify default Active page as the login page .

enter image description here

6
  • Hello Mohith, sorry for this silly question but I am not able to find these settings. Where are these located?
    – Maneesh
    Jun 2 '16 at 13:39
  • Set Up > Sites > Click on the Site Label (Note that Label is not Hyperlinked) Jun 2 '16 at 13:40
  • Salesforce Help Page for setting the active site home page for sites. help.salesforce.com/apex/…
    – Bugude
    Jun 2 '16 at 13:43
  • I don't see any sites here to click on. Any why do I need a public site for this?
    – Maneesh
    Jun 2 '16 at 13:44
  • @ManeeshGupta just search Communities> All communitites> then manage communities and Admin > Pages and then click on Go to Force.com you will find this option. Jun 2 '16 at 14:03
0

https://commsbx-i3vision.cs43.force.com/SupportCommunity/login

Try this link you should be able to login it. I tried I can see username and password screen.

5
  • Yes. I already did that but why the default settings are not working?
    – Maneesh
    Jun 2 '16 at 13:25
  • If you see your page in the page title it says Site Login. I think you have overridden the default login page with your VF page.
    – Shankish
    Jun 2 '16 at 13:29
  • In the manage communities section, click on Administration check what is your Login page.
    – Shankish
    Jun 2 '16 at 13:30
  • The login page is set to Default
    – Maneesh
    Jun 2 '16 at 13:31
  • If its urgent then you can edit the controller and edit the controller and navigate the user to /login page.
    – Shankish
    Jun 2 '16 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.