1

i have a loop that sets alias attribute for each row

%%[
var @title_value, @url_value
var @alias_attr
set @alias_attr = concat("alias","=",'"',@title_value,'"')
]%%

when i inspect the link, seeing below :

<a  
href="%%=RedirectTo(@url_value)=%%" 
%%=v(@alias_attr)=%% 
conversion="true">
    <strong> %%=v(@title_value)=%% </strong>
</a>

from email i click the above link, but displays in the browser url : http://.../life-science-applications-UVVIS-spectroscopy.html?j=1261192&[email protected]&l=467_HTML&u=33618321&mid=6175969&jb=1&cmp=em-mt_1261192&et_cid=em-mt_1261192&et_rid=32594728&Linkid=%%%3dRedirectTo(%40title_value)%3d%%%3fj%3d%%jobid%%%26e%3d%%EmailAddr_%%%26l%3d%%List_%%%26u%3d33618321%26mid%3d%%MemberID%%%26jb%3d1%26cmp%3dem-mt_%%jobid%%%%%3dIIF(EMPTY(identifier7)%2c%22%22%2cConcat(%22%7c%22%2cidentifier7))%3d%%

the linkid is not properly evaluated

what could be the reason?

1 Answer 1

1

Unfortunately, AMPScript in the link alias tags will not get evaluated in the Web Analytics Connector string.

I've been around-and-around with SFMC Support about this. It's one of those little SFMC annoyances that's been around for years.

Previously discussed here: Variables in Alias Showing in Link Level Reporting

1
  • Hi Adam, Even tried to generate the entire to generate the entire html tag but the problem i was facing is RedirectTo was getting evaluated properly. When the links is clicked from email it was not getting tracked, i guess because of RedirectTo was evaluated.
    – shivakumar
    May 30, 2016 at 4:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .