2

I have to import some articles in my org that contain special characters, such as: à,è,ì,ò,ù... But when the import process ends, special characters aren't correctly displayed. I did a massive substitution with html code (e.g. à --> à) but it doesn't work, text still contains à instead of à. I imported them with the standard salesforce tool, reachable from "Data Management -> Import articles" and in the .properties file I setted

CSVEncoding=UTF8
RTAEncoding=UTF8
DefaultHTMLEncoding=UTF8
CSVSeparator=;
#DateFormat=yyyy-MM-dd

Have you have any idea on how to resolve it? Thanks in advance.

  • How are you importing the articles? And where to? In general, import/export tools usually give you the option to select the text encoding when you upload something. If you have the option, you should look for UTF-8. – Renato Oliveira May 25 '16 at 12:04
  • I imported them with the standard salesforce tool, reachable from "Data Management -> Import articles" and in the .properties file I setted CSVEncoding=UTF8 RTAEncoding=UTF8 DefaultHTMLEncoding=UTF8 – DarkSkull May 25 '16 at 12:40
  • 1
    The encoding for UTF-8 has the "-" character between "UTF" and "8". It should be CSVEncoding=UTF-8, for example. Can you try that? – Renato Oliveira May 25 '16 at 12:54
  • No, it doesn't work :( Anyway thank you for you help :) – DarkSkull May 25 '16 at 13:08
  • That's weird, because this help article says that. [help.salesforce.com/… - Are you sure your .csv files are encoded as UTF-8? – Renato Oliveira May 25 '16 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.