2

I can't seem to get the GET /interaction/v1/rest API to function properly. I receive the following data when I call it:

    {'documentation': 'https://code.docs.exacttarget.com/rest/errors/403', 
     'message': 'Not Authorized', 'errorcode': 0
    }

I'm using python request and json libaries here is the code snippet:

url ="https://www.exacttargetapis.com/interaction/v1/rest"
r = requests.get(url, headers = {"authorization":"bearer " + token});
print (r.json());

The token is valid I use it in prior code with other API calls. I recently as in the past 10 minutes updated the App Center ID with the rights to Read Automation Interactions. Is that the correct permissions or is something else needed?

  • based on the limited info you have provided and {'documentation': 'code.docs.exacttarget.com/rest/errors/403', 'message': 'Not Authorized', 'errorcode': 0} have you tried converting your token to a string, this would seem to be causing the error at a first glance – glls May 20 '16 at 3:30
  • What are you trying to accomplish with your REST call? – Adam Spriggs May 31 '16 at 15:32
  • Getting same error, what was the error? – Rasmus Bidstrup Sep 19 '17 at 9:16
  • In my experience, ExactTarget is case sensitive when you use "Bearer " + ... – James Sullivan Jan 26 '18 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.