4

This is a Process Builder/Flow question not Visualforce or Apex, and so I apologize if it's somewhat out of place on here. I'm getting desperate for a solution.

I am currently unable to use a RecordID within the Process Builder and a FastLookup element in a Flow because it is changing from the 15 to the 18 characters ID.

Here is my scenario :

Upon the Approval of a record a Process Builder process is kicked off which (among other things) kicks off a Flow.

ObjectA - the RecordID I want to use for my ObjectB - child object to ObjectA. It is the object with the Approval Process which kicks off the Process Builder process which in turn kicks off the Flow.

Within the Process Builder I am referencing the RecordID of ObjectA and assigning it to a variable used in the Flow.

In the Flow I am using the variable as the key in a FastLookup element in order to pull some fields from ObjectA, and ultimately update ObjectA as well.

But when I reference ObjectA's recordID in the Process it is producing the 18 character ID - and the FastLookup element in the Flow is error-ing out when trying to use that as a key.

If I hard-code a 15 character recordID to the variable in the Process Builder then everything works properly.

I have even tried to solve this by assigning the variable to a Left([ObjectA.id], 15) formula in Process Builder but that still didn't work for some reason. I also made a formula field in ObjectA with the same type of formula : Left(id,15), and just referred to that formula field in Process Builder, and that didn't work either.

So, at this point I'm really out of ideas. I can't see how that Left formula can't work if hardcoding the 15 character ID to the variable will work. It should be the same thing. Any ideas ?

  • Update : I managed to get this to work by assigning the variable to the 18 character ID in the Process Builder - and then re-assigning the variable to a Left(variable,15) formula in the Flow - and then using the variable in the FastLookup. Who knows why that worked instead of just using the formula inside Process Builder. – Zoom_v May 18 '16 at 16:45
  • 2
    questions about Flow, Process Builder or Formulas are just as appropriate here as Visualforce or Apex. It is Saleforce Stack Exchange not Apex Stack Exchange. – Dave Humm May 18 '16 at 17:06
  • 5
    Don't use LEFT(Id, 15), use CASESAFEID instead. – sfdcfox May 18 '16 at 17:09
  • @sfdcfox - I believe I am trying to do the opposite of what CASESAFEID does. Instead of converting a 15 character ID to 18 I am attempting to take only the first 15 characters from an 18 charctr ID. If I attempt to use the 18 charctr ID the FastLookup element in the Flow will error-out when trying to lookup using a variable which has been assigned to that 18 charactr ID. Another weird thing is that a formula field which is only 'ID' shows the 15 characters - but if I assign the variable to objectname.ID in the Process Buildr and then use that variable in the FastLookup it will error-out also. – Zoom_v May 19 '16 at 16:20
  • but again : If I assign the variable to a hardcoded 15 character ID in Process Builder - and then use that variable in the FastLookup element it will all work properly. Very weird problem, very frustrating. – Zoom_v May 19 '16 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.