1

I am making a request to https://webservice.s6.exacttarget.com/Service.asmx. The request looks like this:

<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing"
  xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd"
  xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"
  xmlns:ns1="http://exacttarget.com/wsdl/partnerAPI">
  <soap:Header>
    <wsse:Security soap:mustUnderstand="1">
      <wsse:UsernameToken xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
        <wsse:Username>user@email.com</wsse:Username>
        <wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">123456</wsse:Password>
      </wsse:UsernameToken>
    </wsse:Security>
  </soap:Header>
  <soap:Body>
    <CreateRequest xmlns="http://exacttarget.com/wsdl/partnerAPI">
      <Options/>
      <Objects xsi:type="DataExtensionObject">
        <PartnerKey xsi:nil="true"/>
        <ObjectID xsi:nil="true"/>
        <CustomerKey>Master_User_Table</CustomerKey>
        <Properties>
          <Property>
            <Name>user_id</Name>
            <Value>12345</Value>
          </Property>
          <Property>
            <Name>emailaddress</Name>
            <Value>test@fakeemail.com</Value>
          </Property>
        </Properties>
      </Objects>
    </CreateRequest>
  </soap:Body>
</soap:Envelope>

In my user settings I have "Enabled" set to Yes, and "API User" set to Yes. However, I'm getting this response:

<soap:Body>
  <soap:Fault>
    <faultcode xmlns:q0="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">q0:Security</faultcode>
    <faultstring>Account Disabled</faultstring>
    <faultactor>https://webservice.s6.exacttarget.com/Service.asmx</faultactor>
  </soap:Fault>
</soap:Body>
1

The problem was I was making a request to https://webservice.s6.exacttarget.com/Service.asmx, but I was part of the s7 bucket. I just had to update the url to point to s7 and everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.