5

I have a set of 2 reports, their associated 2 report folders, 2 dashboards, associated 2 dashboard folders.

When I try to deploy via Change Set all of these 8 components, I get this error specifically for the 2 dashboards:

Cannot find a user that matches any of the following usernames: xyz.abc@company.com.changesetcreationsandbox, xyz.abc@company.com.changesetdeploymentsandbox; remove the user from the component being deployed or create a matching user in the destination organization.

I have no idea what is the issue.

I then tried to deploy the 6 components separately and it worked. So the issue seems to be with Dashboards.

I went into Dashboards and also set the Running User as "Run as specified user". Then I created a separate Change Set for these 2 dashboard items and tried to validate it in destination sandbox. Still the same error.

Can anyone please advise what is the issue and how can I resolve this?

  • Are you sure the user exists with the same name in production? For example user@example.com is not the same as user@example.com.sandbox – PepeFloyd May 29 '13 at 20:38
  • Pepe, I do not think the same user should exist in sandbox B. I have deployed Change Sets for Dashboard items created in Sandbox A with different username and deployed in Sandbox B. Each sandbox need to have different username. So I don't know why this issue came up today. – Vimal Desai May 29 '13 at 20:57
  • I am having the same issue deploying a change set from one sandbox to another with Summer 13. I have received a similar error when trying to deploy a dashboard and an outbound message, so it is not strictly dashboard-related. I have logged a case with Salesforce and but they do not yet have an answer for me. – Stacey Chale Jun 14 '13 at 17:38
2

Remove the "run as specific user" completely from the dashboard prior to deployment (set the options to "Run as logged-in user"). Deploy, then change it back to whatever you need.

It tries to find an user by username (in XML of the dashboard definition the reference is stored by username, not by User Id or email). And obviously fails because in production you don't have same sandbox suffix. Same happens when you try to deploy a report/dashboard that's scheduled to be sent to some users or when email alert (from workflows) is being deployed...

Easiest fix is to remove these settings, deploy the "core" of dashboard and amend it manually in the target org.

Alternatively you can temporarily change the username in your target org to be same as the sandbox username (it shouldn't cause login conflicts because the endpoint will still be either login.salesforce.com or test.salesforce.com)... but I believe you'll hit the lockdown of allowed domain names in your production

  • Hello Eyescream, it still fails. Tried to have both dashboards run as logged in user and then created change set for only these 2 dashboards. When I validate it, I still get same error. – Vimal Desai May 29 '13 at 21:12
  • 1
    Open up their XML in the target org (it'll be a link in the "line items" of uploaded changeset) and check contents for occurrence of the username? – eyescream May 29 '13 at 21:14
  • I found this line in the xml : <runningUser>vimal.desai@xyz.com.sourcesandboxname</runningUser>. – Vimal Desai May 30 '13 at 18:56
  • Even after setting their type to "LoggedInUser"? Weird, it shouldn't be present in the XML! You might want to raise a Case with SF support. Only solution I can think of for now is to use Eclipse IDE for deployment, you'll be able to edit the XML and put username with working suffix there :( – eyescream May 30 '13 at 19:17
  • 1
    I got this information from Salesforce Help : In Summer 13 release Salesforce matches users from your development environment (such as a sandbox) to your production organization. If a component in a deployment refers to a user, such as a recipient of workflow email notifications or a dashboard running user, then Salesforce attempts to locate a matching user in the destination organization by comparing usernames. Previously, a change set deployment changed all user references with the user performing the deployment. – Vimal Desai May 30 '13 at 20:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.