1

I've been trying migrating some of my codes using ANT migration tool, including Admin profile.

<types>
    <members>Admin</members>       
    <name>Profile</name> 
</types>

Whenever i try to deployunpackaged from fsandbox to production, i keep getting following unknown user permission errors time to time.The latest one is Unknown user Permission: ViewDataAssessment

and before that I was getting following errors,

  • Unknown user Permission:DelegatedTwoFactor
  • Unknown user Permission:ModerateNetworkUsers

But i was able to compare the profiles between fsandbox and Production and fix it. How can I avoid issues like this in future. Is there any setting i can use to bypass these errors

Thanks, Lahiru

1

You will find many hits if you Google this and it is posted in the "Known Issues" Summer 14- Force.com project fails with "Unknown user permission" so add yourself there.

Manual (or scripted) editing of the profiles is the normal workaround. This is the sort of problem that some of the paid-for release management tools might automatically work-around.

| improve this answer | |
  • Thanks Keith, i tried to find the setting (ViewDataAssessment) on the profile but couldnt so. any help? – L Mudiyanse May 13 '16 at 13:25
  • @Lahiru I would expect that ViewDataAssessment to be present in one of the profiles or permission sets you are deploying so its weird if its not there. – Keith C May 13 '16 at 15:11
0

Seems to me your sandbox is already on Summer '16, while your production still is on Spring '16. These are new permissions that have been added in the new version, and thus do not yet exist in your production environment.

According to me, best thing to do is to plan your sandbox refreshes accordingly. You are notified about this by Salesforce upfront. You can also read more about this on their blog.

Try to make sure your source and target environment will be on the same version whenever you plan to deploy.

If this is no longer possible, you can also manually remove the reference to that specific profile permission before deploying.

| improve this answer | |
  • Thanks Robin, i tried to find the setting (ViewDataAssessment) on the profile but couldnt so. any help? – L Mudiyanse May 13 '16 at 13:25
  • Could it be related to this? – Robin De Bondt May 13 '16 at 14:26
  • Experienced the exact same issue, and found the setting under App Permissions => 'Sales' section => Access to view Data Assessment. Weird since I'm deploying to another sandbox which is on the same version (Summer '16). – Robin De Bondt May 17 '16 at 14:42
  • I believe this issue is due to a Clean Rule (Data.com Administration => Clean) that has been installed by sfdc. I got a 'Company Info for Accounts' rule in my source org, 'Created By Automated Process' some days ago, which I do not have in my target org... No idea how or why it got there though. – Robin De Bondt May 17 '16 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.