3

I originally had a "Remote Access" app in a developer org. I am still using this today to log Cases's via a web form. I wanted to make a few changes and I can't find it via Setup...I have checked the Connected Apps section under Create -> Apps and the alternative under Manager -> Apps with no joy. I have also searched for Remote Access and I can't seem to find it.

I can see it "exists" as the Login History shows the App's access to the Org.

Anyway - can anyone shed some light on where the App can be found?

  • 1
    Is this local or part of package?? – Mr.Frodo May 12 '16 at 13:45
  • Local - no packages/apps installed in this org – sfdc_beginner1 May 12 '16 at 14:00
  • Do you have customize application permission on your profile?? – Mr.Frodo May 12 '16 at 16:32
  • Thanks and yes :( Is there anyway to find it via SOQL? I plan on using the force.com IDE tomorrow to see if I can find it with that (I couldn't with Octopus) – sfdc_beginner1 May 12 '16 at 16:38
  • Yes it is possible.Writing it in answer. – Mr.Frodo May 12 '16 at 16:41
0

You can try to find it through SOQL as well.It's the ConnectedApplication object.

SOQL would be something like this:

SELECT Id, Name FROM ConnectedApplication

From Comments:

To read connected apps one must have customize application permission.For more information refer this Documentation

Edit:

Remote Access applications have been replaced by connected apps

So i think my solution is still valid.

  • unfortunately it doesn't display anything - can you advise the SOQL for remoteaccess? I have tried again and the login history still shows the app...just can't find it in the org :( – sfdc_beginner1 May 12 '16 at 21:02
  • What do you mean by remoteaccess?? I'm assuming that you are running this query from the developer console in the org which have or had the connected app ?? – Mr.Frodo May 13 '16 at 5:15
  • Hi, this is what I mean by remoteaccess: help.salesforce.com/apex/…. That is how it was originally set up, actually using this: developer.salesforce.com/page/… – sfdc_beginner1 May 13 '16 at 7:41
  • Thanks for the help - except - my question/problem is basically I can't find the "app"? As remote access is deprecated I can't find it there and it hasn't displayed under Connected Apps...how can I view the app/change the settings etc. I know I could simply create a new one but I want to cover all my bases with this old one first - is it a bug it hasn't become available in connected apps? – n34_panda May 13 '16 at 8:19
  • You have to consider the fact that connected app can be deleted.Apart from permissions i think that could only be the reason.You should try to contact support.Maybe they can help you. – Mr.Frodo May 13 '16 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.