5

I have installed a Managed Beta Package in a Group edition Org. I have a Apex batch job which runs onClick of a button and saves the results to a Custom Object.

I then display the results in an apex:pageBlockTable. The issue is: I don't see any result in the table, i.e. it shows me there are 6 rows but does not display any values in the columns. Not even in any one of them.

In the Last 2 columns I have Custom Buttons which perform CRUD operations on individual row elements. I see the buttons and when you click on one of these buttons, I get "System.QueryException: List has no rows for assignment to SObject".

Here is a preview: EmptyTable

Can anyone tell me whats going on here?? Why do I see empty rows?? Are batch jobs supported in GE/PE??

Same issue with Professional Edition as well. Although it works perfectly fine in EE, UE and DE orgs.

Any help would be highly appreciated.

Best, Taneja

1

Your problem is that GE and PE editions do not have access to the Bulk API. You might want to look at the following references: Features Available in Group and Professional Editions, API Access in Group and Professional Editions, and Using Apex in Group and Professional Editions.

| improve this answer | |
  • I'm hearing that "Batch APEX" isn't considered part of the Bulk API am I misinformed? I'm trying to run batch apex in GE and it doesn't seem to be executing. I'm not saying your incorrect, but there isn't an explicit explanation I can find in the documentation. – jordan.baucke May 31 '13 at 16:42
  • Those editions don't support any Apex other than in managed packages, so you don't have the option of running scheduled "batch jobs" like in other editions. But you're correct that the Bulk API isn't the same as "Batch Apex" since it has to be enabled separately. Its really a combination of REST and LARGE Batch Apex jobs that obviously incorporate @future calls, with one diff being that batches can run in parallel. – crmprogdev May 31 '13 at 18:46
  • Hi All, Sorry for delay in reply!! MY question still remains, if the Bulk API is disabled, why do I still see the 6 blank rows. Like, there is some logic being executed in Batch Class as there should be 6 rows there according to the data I have. There are 6 objects of Custom Object being inserted but with no value. Another thing, I have another Custom Object, which stores data for another functionality, and displays the result in similar format. That is working totally fine in GE/PE. When I try to display that object values in this page, the result is the same. Blank rows and more blank rows:( – ankittaneja Jun 6 '13 at 13:43
  • You also don't have access to APEX methods exposed as SOAP. Metadata API is also unavailable. Also can't use Ajax Toolkit with custom JavaScript. Unless you've had your App "whitelisted", you don't have access to REST or APEX methods that use REST. Seems like some of those could easily apply from the description of your problem. Does that help give you any direction to solve the problem? If not, perhaps you could post some code for the page & controller. – crmprogdev Jun 6 '13 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.