4

Summer 16 update has brought some issues to a Salesforce One mobile app I have been working on. The two issues I have had are the following.

All hyperlinks (even ones with just a # in the href and an onclick action) now open up what seems to be a built in web browser. If I close this pop up web browser my JavaScript in the background has completed, this did not happen until the summer 16 update over the weekend. Buttons do not have this issue. The Address in the browser pop up is "https://customName.lightning.com.force.com/native/bridge.app#" The # seems to be what was in my Href value. How do I stop this from happening?

The second issue is. Any form of scrolling on any of my custom components no longer works, even just a very basic component of just text.

<aura:component implements="force:appHostable" > Huge Wall Of Random Text Here </aura:component>

Will not scroll, before the summer 16 update vertical scrolling functioned fine now text just writes off bellow the page that can not be seen, also the pull down to refresh no longer works on custom components. How do I re-enable scrolling in my Salesforce One app?

  • I have noticed that the default Salesforce 1 pages such as The Feed now scroll slightly differently. Instead of just scrolling when I push or pull anywhere on the page its only in the feed area in the center that scrolls. I'm guessing this relates to my issue with scrolling and I need to use some sort of class or element to create a scrollable area? – Ashley Colman May 10 '16 at 1:32
  • I've brought this to the attention of the owners of this area and asked them to comment here asap. – Doug Chasman May 10 '16 at 12:48
  • Some changes were made this release in the default scrolling behaviour. We wanted to give users more control over regular scrolling (and also support SLDS). We will try your example and we will give you an update shortly once we understand the problem and have some potential fixes and workarounds for you to try. – Diego May 10 '16 at 13:47
  • @Diego Do you have any information on this? both issues have fundamentally broken my Salesforce1 app and the silence is not giving me much confidence to continuing using this platform. Using a hyperlink to call a javascript function in my controller and being able to scroll are both very core and fundamental features I would hope are not issues.. – Ashley Colman May 12 '16 at 23:56
  • Scrolling is something that we are proactively working on, and we will be deploying fixes as soon as possible, to address some of the main blockers that customers are reporting. A holistic fix to allow default browser scrolling behaviour and complete control over scrolling, will be worked for our next release. In our current architecture we use the hash # part of the URL to preserve the state (reason is fundamentally browser support when we started S1). So unfortunately we will not be able to support #anchor links for now. – Diego May 15 '16 at 18:15
1

A temporary solution to enable scrolling is to wrap your component inside a flexipage. When the component utilized the Lightning App Builder as a wrapper, there are no issues with scrolling. To do this, modify your current Lightning Component as follows:

Modify from:

<aura:component implements="force:appHostable" >

To:

<aura:component implements="force:appHostable,flexipage:availableForAllPageTypes" >

and save the changes. From there, create a Flexipage by going to the Lightning App Builder and selecting to create a new Flexipage. With the modifications listed above, you should now see your custom component in the custom component section. Drag the component into the Flexipage. Then save and activate the Flexipage. Once activated, go to the Salesforce1 app, clear the cache and test the Flexipage that you just created. HTH!

By the way, Salesforce has confirmed the permanent fix for this is scheduled for the 202.5 Summer '16 patch for Sandboxes, which will be released in approximately two weeks (Safe Harbor). Here is the link to Known Issue.

  • Excellent thank you for the work around and link to the known issue. The work around has worked for me and will mean we can continue UAT! – Ashley Colman May 13 '16 at 16:51
0

I have found an answer to the hyperlinks opening the built in browser issue.

Remove the href tag. By making the hyperlink a Place Holder Hyperlink the inbuilt browser does not pop up. <a class="tabButton">Deals</a>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.