0

After we upgraded our sandbox to summer 16, I observed that in lightning components container size is not scrolling. Earlier the container size would update automatically. I tried firing ui:updateSize event, but that also didn't work. Does anyone know what could be the issue here and are there any workarounds? I have gone through the release notes but couldn't find anything.

Any help will be appreciated.

1

I faced the same issue last week. Salesforce has provided temporary workaround for this.

If you are using the component for SF1, the workaround is to wrap your component inside a flexipage. When the component utilized the Lightning App Builder as a wrapper, there are no issues with scrolling. To do this, modify your current Lightning Component as follows:

Modify from:

<aura:component implements="force:appHostable" >

To:

<aura:component implements="force:appHostable,flexipage:availableForAllPageTypes" >

and save the changes. From there, create a Flexipage by going to the Lightning App Builder and selecting to create a new Flexipage. With the modifications listed above, you should now see your custom component in the custom component section. Drag the component into the Flexipage. Then save and activate the Flexipage. Once activated, go to the Salesforce1 app, clear the cache and test the Flexipage that you just created

Edit: Please find the link to the known issue created. You can select the green box "This Issue Affects me" and you will receive notifications when the doc is updated and when it has been resolved.

  • Thanks for the workaround. However the issue is shown as fixed now, but its still not working without workaround. Weird! – Mahesh May 16 '16 at 12:58
0

This seems to be related to a change in default scrolling as described here!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.