3

My Dev sandbox seems to be API version 36 and our other sandboxes (and production) are API version 37.

This means I cannot deploy changesets into our Dev sandbox. Is there any workaround to do that

3
  • just change you artifacts version from 37 to 36 and then deploy
    – Ratan Paul
    Commented May 9, 2016 at 14:47
  • 1
    @Ratan Some artifacts or components cannot be upgraded at all and those needs to be removed from the changesets .Specially if there is a new metadata that's been added by salesforce those cannot be propogated and may break whole changeset Commented May 9, 2016 at 15:00
  • @MohithShrivastava ahh you are right..'
    – Ratan Paul
    Commented May 9, 2016 at 15:20

1 Answer 1

5

You cannot deploy components that are version 37.0 until your Production org is updated to new release .

There are certain components that you may downgrade (like apex,VF,components) using IDE and still deploy but for some components where salesforce does not provide ability to downgrade you will still not be able to move to PROD .

In case you are interested in Summer 16 release dates please see below

May 20th: NA44 and NA45 are upgraded

The first release weekend is when we here at Salesforce and any customers on NA44 and NA45 are upgraded.

June 3rd: The second release weekend

This is when another set of instances - NA6, NA7, NA8, NA9, NA17, NA18, NA22, NA28, NA29, NA31, EU5 - gets upgraded.

2
  • My issue is that dev1is 37 and dev2is 36 and dev3is 37. Our development process goes from dev1-> dev2-> dev3. All are sandbox.Is there any possibility Commented May 9, 2016 at 17:06
  • You wil need to wait till dev2 is upgraded as well .You can clone a sandbox with new release .May be try cloning the dev1 box and create a new box or else you can skip dev 2 box Commented May 9, 2016 at 17:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .