5

I'm trying to define some criteria in process builder that checks to see if a user was selected in an Assign to User custom lookup field. However, process builder won't let me select that field for the criteria. I am required to traverse the lookup field and select a field on the user object. Is there a way around that? I just need to check if that field != null.

Set Conditions Screen

enter image description here

  • Can you explain your problem briefly..@Allen Mann – Pavan tej May 6 '16 at 13:54
  • I have a Quick Action for Case Feed that has an Assign to User field. It is a lookup field to Users. So, in process builder I need to define criteria for the action. If Assign_to_User__c != null I want to continue the process. But I do not see a way to just select that field, I am required to use "Assign to User >" like shown in my screenshot above. – Allen Mann May 6 '16 at 13:58
6

Instead of using the Conditions are met you could use Formula evaluates to true and use a formula to determine if it has a value.

enter image description here

  • Ya it works definitely and my suggestion is instead of using ISNULL use ISBLANK @Allen Mann – Pavan tej May 6 '16 at 15:00
2

I was able to make the not null check by using $GlobalConstant.Null when the Type is set to Global Constant.

enter image description here

0

You need to scroll down a little bit and you will find the field Assign to user.

What you are seeing in image is relationship field.

  • I thought the same, but it's not there. – Allen Mann May 6 '16 at 13:57
  • it must be there, try to type 'assign' in the search box – C0DEPirate May 6 '16 at 13:59
  • Updated post with screenshot of available fields searching for "assign". Still nothing =( – Allen Mann May 6 '16 at 14:13
  • 1
    Strange, I am not very sure will it help or not, can you double check what is the label and API name of the field? – C0DEPirate May 6 '16 at 14:17
  • What @C0DEPirate suggests, please also see success.salesforce.com/ideaView?id=08730000000DfGAAA0 You must search for the API name, not the label. A known bug/feature. – Sander de Jong May 9 '16 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.